Announcement

Collapse
No announcement yet.

No sound from daughter board

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No sound from daughter board

    Hello All,

    I Need help debugging the lack of sound from daughter board.

    I bought the Transmitter and Receiver/Recorder+sound a couple of months ago but just recently started working with the system. From the start, had a number of issues ranging from difficulty connecting the live RF link to basic playback. After many hours, changing batteries, reseating the daughter board, deleting the mp3 folder and copying the 0001 and 0002 sound files to the SD card, everything worked!!! I could live puppeteer, play sound files and tracks, and program routines.

    But during the programming of new routines, I'm stuck now where I can easily live puppeteer and record but I can no longer get the sound to play. I have tried all of the usual tricks of reseating the daughter board and the SD card and deleting the mp3 folder and copying back the demo files starting with 0001.

    some details.
    - when everything worked, the red light on the SD card module stood lit. Now that things don't work, the red light flashes for a fraction of a second after reset.
    - PGMing is working fine now. I was able to record a program using all tracks mode (rec button only) of about 45 seconds. The track plays back my servos like I recorded them.
    - I tried using a different SD sound card (I added the mp3 folder to the 128 MB SD card from a version 2.0 recorder/receiver SD card and also another SD card)
    - I tried deleting the mp3 folder and copying files again over a dozen times
    - the receiver/recorder config.txt file is the same one that came with board with the one exception that I put servo limits in. Otherwise, the sound settings are unchanged.
    - I checked that I do have 5V at the daughter board.

    What should I try next?

    thanks!
    Last edited by laultima; 10-24-2021, 10:20 PM.

  • #2
    I'm happy to help!

    Usually in situations like this, power is the #1 issue. How are you powering the board, do you have any servos plugged in and how are they powered? What do you have the servo power jumpers set at?

    It is possible that the board is suffering a power brown out and is causing the main processor to glitch and the SD card stops writing.

    BoffinAndre

    Comment


    • #3
      Thanks for the quick reply.

      I am powering the board with the single supply approach using a 6V 5Amp AC power adapter (black box similar to laptop adapter) and all servo jumpers set accordingly. I also thought that maybe need closer to 9 volts and used a 2A bench supply set to just under 9V, Same results.

      And my project has 3 servos, I disconnected them but still no ambient sound and no triggered sound during playback. At that point, i expect minimal current draw.

      My experience has been that if I get something wrong on the on the SD card, like file name missing a zero or copy order, that I get no steady red LED on the SD card so that is what I have been chasing.

      I'll try the following next:
      - a new SD card. (will a 16GB class 10 card work for sound?)
      - a different power supply. (will a 9V battery work if there are no servos attached?)

      any other suggestions?
      Any debug like output pin levels or LEDs that I can read?

      Comment


      • #4
        If a brown out did happen, it could have corrupted the config file on the Receiver Recorder SD card which then wouldn't tell the sound board to play. It would be a good test to replace the files on the SDcard with fresh copies from the Github page - https://github.com/addicore/Boffintr...eiver-Recorder as well as replacing the files on the sound SDCard.

        There is a 5v regulator on the Receiver Recorder that has a max output of around 1A. If your servos are going to be drawing anymore than that, it is recommended to run a 2nd power supply and change the jumper settings.

        BoffinAndre

        Comment


        • #5
          Not having any luck with the sound board and now the recorder is giving me trouble.

          - I managed to upgrade a second recorder from 2.0 to 3.1 and updated the config.txt and track files with the 3.1 demo and put the daughter board on this second board. same results, no sound and no red LED.
          - i swapped out the sound SD card with a newly formatted card with fresh copies of the sound files. no sound
          - swapped the daughter board between the 2 recorder boards with many combinations of recorder SD cards and sound cards, no sound.
          - I tried a 9V 1A wall wart with no servos plugged in on both recorder boards. no sound
          - eventually, I lost the green LED on one of the recorder boards (the one that came with 3.1 and the daughter board). I checked voltage at the 5V regulator near Vin and see 6.4 volts at the input but nothing on the Vout pin. I see 5.5 volts at the VS5 headers.

          Next steps:
          - I ordered a new sound card that I will try with my second recorder.
          - I saw the email where you sent me a return label. I will be returning the recorder and the sound board

          thanks for the support.

          Comment


          • #6
            I was just helping another customer with a similar issue and he had plugged the soundboard in backwards onto the receiver. Check that yours looks like the picture here - https://www.addicore.com/Boffintroni...nd-p/ad587.htm

            I am curious to see if the soundboard I just shipped out works in your setup or if there is a problem with your Receiver Recorder.

            BoffinAndre

            Comment


            • #7
              Hello BoffinAndre,

              Finally sorted everything out just in time for Halloween!

              I basically started again from scratch with all of the SD cards and then took a closer look at the my power supplies. I found that the 9v power supply that I was using worked fine when I had the servo load on it but then was unstable if more than 1 amp was drawn giving me unpredictable results. And even worse, that supply that I thought was regulated was not! When I added a separate servo supply, the load on the 9v supply went down and it pumped out as much as 14volts! Eventually fried the primary 5V regulator on two recorder boards. I replaced the SMD regulators and recovered one board that works fine with my sound cards now. The other recorder board is toast; has 5 volts everywhere, just will not boot.


              My advice to everyone new to these boards is to do as u suggested:
              • make sure SD cards are not corrupted
              • double and triple check the config recorder config file settings, including the sound enable bit and other sound settings
              • check the sound file names to make sure they are in the right subdirectories and have the correct number of zeroes, copy order, etc.
              • examine the supply specs. measure the supply before and after its plugged in. Don't assume that its properly regulated.

              Thanks again for the help!

              I'll post a video of my project soon.

              Comment

              Working...
              X